Comunicados

  • 08/05/2024

    Nueva versión de Requerimientos OSAM - 11.1

    Actualización de los requerimientos técnicos para el desarrollo de aplicaciones móviles para el Ayuntamiento de Barcelona a la versión 11.1.

    R1.1.3 - Este requisito ya no es obligatorio y pasa a ser una recomendación. 

    R1.6.2 - Se ha modificado la redacción y se ha indicado el asunto que se debe poner en el correo de contacto. Además, la explicación del módulo común para obtener la información del dispositivo se ha movido al R1.7.1. 

    R1.7.1 - Se ha añadido la explicación de la funcionalidad de obtener información del dispositivo y de la aplicación como una tercera funcionalidad después del control de versiones y el control de valoraciones.

    Les recordamos que pueden consultar los requisitos aquí, en la sección de "Información destacada para la publicación de aplicaciones móviles".

  • 09/02/2024

    Nueva versión de Requerimientos OSAM - 10.3

    Actualización de los requerimientos técnicos para el desarrollo de aplicaciones móviles para el Ayuntamiento de Barcelona en la versión 10.3.

    R1.2. - Se han actualizado las guías de estilo enlazadas en este requerimiento. Más detalle.

    R2.1.1 - El desarrollo debe ser compatible con iOS16 o versiones superiores. No se publicarán aplicaciones compatibles con versiones de iOS 14 o anteriores. Más detalle.

    R3.1.1 - Las nuevas aplicaciones y actualizaciones (a partir de mayo) deben estar orientadas como mínimo a Android 14 (API 34). Más detalle.

    El cambio en el requerimiento R1.2. implica que ha habido cambios en el diseño de algunos recursos, como el icono de la aplicación o el splashscreen, y que estos cambios deben realizarse tanto para nuevas aplicaciones como en las actualizaciones de aplicaciones existentes. Este requerimiento es de obligado cumplimiento desde el momento en que se envía este correo.

    Os recordamos que podéis consultar los requisitos aquí, en la sección de "Información destacada para la publicación de aplicaciones móviles".

  • 12/12/2023

    No se liberarán versiones en los mercados de iOS y Android del 22 de diciembre de 2023 al 7 de enero de 2024

    No liberaremos ninguna versión de la aplicación móvil en los mercados de iOS y Android que no haya sido previamente planificada con los jefes de proyecto correspondientes de OSAM. En caso de necesidad, por favor, póngase en contacto con él.

     

    Este calendario solo afecta la liberación de las versiones, ya que todos los procesos de publicación relacionados con el ciclo OSAM se mantendrán con normalidad (validación de versiones de desarrollo, compilaciones, distribución por Firebase, smoketest, soporte, entre otros).

    En caso de que ocurra una incidencia significativa en el entorno de producción, estaremos disponibles para su publicación, si es necesario.

  • 28/11/2023

    Nueva versión de Requerimientos OSAM - 10.2

    Actualización de los requisitos técnicos para el desarrollo de aplicaciones móviles para el Ayuntamiento de Barcelona a la versión 10.2.

    • R1.1.6.4 – Se debe informar antes de la publicación de una nueva versión si esta será full roll-out o progresiva. Más detalle.
    • R1.2.2 - Se ha modificado este requisito, eliminando el apartado referente a la icona de favoritos. Más detalle.
    • R1.11.2 – Ahora es obligatorio cumplir con los criterios de calidad de código indicados en SonarQube. Si no se cumplen, la aplicación no se publicará. Más detalle.
    • R3.3.1 – Se ha aclarado este requisito, explicando que implica mostrar una nueva pantalla que cumpla con los requisitos de diseño para el splash screen. Más detalle.

    Os recordamos que podéis consultar los requisitos aquí, en la sección de "Información destacada para la publicación de aplicaciones móviles".

  • 18/07/2023

    No se liberarán versiones en los mercados de iOS y Android del 28 de julio al 1 de septiembre (2023)

    No liberaremos ninguna versión de la aplicación móvil en los mercados de iOS y Android que no haya sido previamente planificada con los jefes de proyecto correspondientes de OSAM. En caso de necesidad, por favor, póngase en contacto con él.

    Este calendario solo afecta la liberación de las versiones, ya que todos los procesos de publicación relacionados con el ciclo OSAM se mantendrán con normalidad (validación de versiones de desarrollo, compilaciones, distribución por Firebase, smoketest, soporte, entre otros).

    En caso de que ocurra una incidencia significativa en el entorno de producción, estaremos disponibles para su publicación, si es necesario.

  • 11/04/2023

    Nueva versión de Requerimientos OSAM - 10.0

    Se han actualizado los requerimientos técnicos para el desarrollo de aplicaciones móviles para el Ayuntamiento de Barcelona a la versión 10.0. Aquí tienes un breve resumen de las novedades:

    • R1.11. Se ha reorganizado este requerimiento, dividiéndose en un apartado (R1.11.1) que hace referencia a los test plan, y un nuevo apartado (R1.11.2) que lo hace a la calidad de código y que, hasta el tercer trimestre del 2023, solo es una recomendación. Más detalle
    • R3.1.1. Las versiones Android deben ser compatibles con la versión 8.0 (API 26) y superiores del sistema operativo. Más detalle

    También se ha actualizado el procedimiento de publicación de aplicaciones móviles, añadiendo un apartado nuevo:

    Caducidad de las versiones preparadas que publicar en función del número de días que la versión se mantenga en este estado antes de liberarla en los markets. Más detalle
     

  • 16/03/2023

    Nueva versión de Requerimientos OSAM - v9.5

    Hemos actualizado los requerimientos técnicos para el desarrollo de aplicaciones móviles para el Ayuntamiento de Barcelona a la versión 9.5.

    Un breve resumen de las novedades de esta versión:

    R1.3.2. Debe mostrarse un mensaje en la parte inferior de la pantalla recordando a la persona usuaria que ha denegado un permiso de la aplicación. También se han indicado las instrucciones para solicitar el permiso para gestionar correctamente las notificaciones push en dispositivos Android 13 o superior.

    R3.1.1. Las nuevas aplicaciones deben estar orientadas a Android 13 (API 33). A partir de mayo también será obligatorio para actualizaciones.

    R3.3. A partir de Android 12 cambia la forma de implementar la splash screen.

    Recordamos que puedes ver todos los requerimientos actualizados haciendo clic aquí.

    Qué ofrecemos > Servicios > Oficina de servicio al móvil > Información destacada para la publicación de aplicaciones móvile

  • 31/01/2023

    Nueva versión de Requerimientos OSAM (v9.4)

    Hemos actualizado los requerimientos técnicos para el desarrollo de aplicaciones móviles para el Ayuntamiento de Barcelona a la versión 9.4.

    Un breve resumen de las novedades de esta versión:

    R1.5.1. Registro del idioma del dispositivo e información sobre el idioma seleccionado al iniciar la aplicación.

    R1.6.2. Utilización del módulo común de la OSAM para obtener la información del dispositivo y añadirla al correo electrónico de contacto.

    R1.6.6. Si la funcionalidad de una aplicación implica cómo llegar a un destino, y este te lleva fuera de la aplicación, hay que indicar al usuario la posibilidad de seleccionar entre las diferentes aplicaciones de navegación que tiene instaladas en su dispositivo.

    Recordamos que en el espacio de información destacada para la publicación de aplicaciones móvil de la página web de la OSAM puedes ver todos los requerimientos actualizados.

    Qué ofrecemos > Servicios > Oficina de servicio al móvil > Información destacada para la publicación de aplicaciones móvile

  • 12/06/2022

    Nueva versión de Requerimientos OSAM - 10.1

    Se han actualizado los requerimientos técnicos para el desarrollo de aplicaciones móviles para el Ayuntamiento de Barcelona a la versión 10.1. Aquí tienes un breve resumen de las novedades:

    • R1.4.3 - Las aplicaciones deben tener un sistema para deshabilitar las llamadas a servicios, tanto de terceros como propios. Más detalle.
    • R1.11.2 - A partir de octubre, será un requisito cumplir con los criterios de calidad de código para la publicación de aplicaciones. Más detalle.
  • 17/05/2022

    Nueva versión de Requerimientos OSAM (v9.0)

    Hemos actualizado los requerimientos técnicos para el desarrollo de aplicaciones móviles para el Ayuntamiento de Barcelona a la versión 9.0.

    Hemos actualizado los requerimientos técnicos para el desarrollo de aplicaciones móviles para el Ayuntamiento de Barcelona a la versión 9.0.

    En esta nueva versión de los requerimientos se ha realizado una revisión a fondo, actualizando o eliminando aquellos que estuvieran obsoletos. También se han añadido nuevos requerimientos, entre ellos dos que queremos destacar:

    R1.7.3. Módulo común OSAM

    La OSAM ha desarrollado una nueva librería que contiene y mejora las funcionalidades del módulo de control de versiones y del módulo de valoraciones. Esta nueva librería, de nombre módulo común OSAM, será de uso obligatorio con las siguientes condiciones:

    Todas las aplicaciones nuevas deben integrar el módulo común de la OSAM.

    A partir del 1 de setiembre de 2022, todas las actualizaciones de las aplicaciones del Ayuntamiento deben integrar el módulo común.

    R1.14. Integración con la cartografía municipal

     

    El framework oficial de mapas para las aplicaciones del Ayuntamiento es Mapbox y, por lo tanto, es de uso obligatorio para aquellas aplicaciones con ámbito territorial exclusivo en Barcelona. Esta obligatoriedad toma la siguiente forma:

    Todas las aplicaciones nuevas deben integrar Mapbox y utilizar la cartografía municipal del Ayuntamiento.

    A partir del 1 de enero de 2023, todas las actualizaciones de las aplicaciones del Ayuntamiento deben integrar Mapbox y la cartografía municipal.

    Un resumen del resto de los cambios más importantes de esta versión:

    R1.1.4. Hay que utilizar Flutter para nuevos desarrollos

    R1.5.3. Debe haber un topic por enviar notificaciones push a una versión determinada

    R2.2. La nomenclatura del campo bundle tendrá el siguiente formato: yyyymmddhh

    Recordamos los enlaces a los requerimientos:

    CAT: http://www.bcn.cat/mobil/apps/docsdsv/requerimentsAppsAjmnt_ca.htm

    ES: http://www.bcn.cat/mobil/apps/docsdsv/requerimentsAppsAjmnt_es.htm